Help Support Bigcoupe.com

Cranks but Won't start - Got Spark, Fuel, Compression

Post here for mechanical and engine topics such as fuel issues, transmission problems, rough idle, exhaust, electrical issues, etc

Moderators: ron, bfons, GRNSHRK

Post Reply
angad22
Posts: 10
Joined: Sun Nov 29, 2015 12:43 am
Location: Newark CA

Cranks but Won't start - Got Spark, Fuel, Compression

Post by angad22 » Tue Oct 16, 2018 4:35 am

I was out driving my 1980 Euro 635csi when it just quit waiting at a red light. Cranked it however it did not start and finally had to get it towed to the shop. The mechanic checked the fuel pump that we had replaced few months back and found good fuel pressure, then checked the coil which was also working fine, the plugs were ok too so cleaned them and put them back, the fuel pressure and main relay are in working condition, checked compression at all cylinders which is also in great however the engine refuses to start. We put some started fluid however it still did not start. Not sure what the issue is here.
Has anyone had similar situation?
Also does anyone know where to find a repair manual or wiring diagram for 1980 Euro 635csi?
Angad

User avatar
hornhospital
Bigcoupe supporter
Posts: 2297
Joined: Sun Jul 11, 2010 6:46 pm
Location: Silverhill, AL
Contact:

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by hornhospital » Wed Oct 17, 2018 1:39 am

If it won't fire on starter fluid you have no spark. Check the distributor innards. I'm thinking the rotor failed.
Ken Kanne
'84 633CSi "Sylvia"; '85 635CSi "Katja";'87 325is "Odette"; '93 325is "Elvira"; '95 M3 "Ashlyn"

Pod
Bigcoupe supporter
Posts: 3890
Joined: Tue Mar 16, 2010 8:32 pm
Location: usually in the barn, Kent, England.

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by Pod » Wed Oct 17, 2018 1:07 pm

I agree. Check for sparks. Also make sure the two pulse generator cables are properly plugged in and/or working.

ron
Senior Member
Posts: 4352
Joined: Sat Jul 10, 2004 11:35 am
Location: South Wales U.K.

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by ron » Wed Oct 17, 2018 2:40 pm

angad22 wrote:
Tue Oct 16, 2018 4:35 am
Also does anyone know where to find a wiring diagram for 1980 Euro 635csi?
Contact "olympia57"
They are ALWAYS rustier than you thought!!!!!!
'88 High line.
'85 M #228
'85 M #207
'80 735i

GRNSHRK
E12 Based Guru
Posts: 2605
Joined: Thu Apr 08, 2004 3:24 pm
Location: Sunnyvale (SF Bay Area) CA

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by GRNSHRK » Wed Oct 17, 2018 5:49 pm

+2 on the "no spark" issue, but as I have an L-jet equipped 6er, I'm not exactly sure what Pod is referring to, "two pulse generator cables" :-k

Whenever I had running issues, it was always related to the combo relay failing :-&

You mention "main relay", can you please expand on that :-?
:mrgreen:
Bobbo
1980 633 CSi
Cypress Green/Pearl Beige
2011 F10 528i
2005 E46 330 Ci ZHP Cabrio
Image

You can never have too many BMW's

angad22
Posts: 10
Joined: Sun Nov 29, 2015 12:43 am
Location: Newark CA

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by angad22 » Wed Oct 17, 2018 10:40 pm

Sorry I was referring to the combo relay. My mechanic replaced it with another one he had in a parts car. We also noticed some metal shavings in the distributor after removing the rotor and the plastic plate. Will replace the distributor with another used one to see if it starts.
Angad

Pod
Bigcoupe supporter
Posts: 3890
Joined: Tue Mar 16, 2010 8:32 pm
Location: usually in the barn, Kent, England.

Re: Cranks but Won't start - Got Spark, Fuel, Compression

Post by Pod » Wed Oct 17, 2018 11:42 pm

GRNSHRK wrote:
Wed Oct 17, 2018 5:49 pm
+2 on the "no spark" issue, but as I have an L-jet equipped 6er, I'm not exactly sure what Pod is referring to, "two pulse generator cables" :-k
Whoops :oops: wrong engine, sorry.

Post Reply

Who is online

Users browsing this forum: No registered users and 10 guests