Help Support Bigcoupe.com

1 Tail light housing dead

Post in this forum for topics relating to the exterior. This includes body, windows, and accessories

Moderators: ron, bfons, GRNSHRK

Post Reply
joeg
Posts: 59
Joined: Fri Jul 17, 2015 1:59 am
Location: NY

1 Tail light housing dead

Post by joeg » Sat Apr 02, 2016 8:02 pm

My driver's side tail light housing doesn't seem to be getting power anymore. None of the bulbs are working and i tested the bulbs by switching them to the other side with bulbs that work. Both bulbs work on the passenger side, none on the driver side. I checked and reseated every connector/wiring harness back there, I wiggled everything hoping to find something loose... nothing. Fuses under the hood all look good and unless i'm mistaken the fuse would control both housings.

What am I missing?
1980 Euro 635CSI

User avatar
dwcains
Bigcoupe supporter
Posts: 1477
Joined: Sun Sep 14, 2014 6:01 am
Location: Lutz, FL

Re: 1 Tail light housing dead

Post by dwcains » Sat Apr 02, 2016 8:27 pm

I'd be looking for a bad ground.
Dean
Lutz, FL

'85 635 CSi Euro #9402254
'87 Spider Veloce
'92 Spider Veloce
'08 350Z

Image

User avatar
Ralph in Socal
Bigcoupe supporter
Posts: 2252
Joined: Tue Apr 14, 2009 3:32 am
Location: High Desert of SoCal

Re: 1 Tail light housing dead

Post by Ralph in Socal » Sat Apr 02, 2016 8:30 pm

Control unit in the middle of the rear trunk panel. Located right next to the lock mechanism. Check those connections - in to, and out of the unit.

And don't forget that all the signal/emergency lights go through the Flasher Switch.


Ralph
There is a very fine line between "Hobby" and Mental Illness.

85 635csi Zinno Auto
84 528i Euro
83 635 Euro Arktik
81 528i Kastanien 5-speed
88 528e Bronzit (Granpa Car)
86 535i Auto (For Sale)
81 633 csi (retired)

joeg
Posts: 59
Joined: Fri Jul 17, 2015 1:59 am
Location: NY

Re: 1 Tail light housing dead

Post by joeg » Sun Apr 03, 2016 12:18 am

I'll try grounding the lights and see if they go on.

Ralph, I don't see the control unit. Are you sure it was on the early 6's? There's nothing really near the lock. On each side, there is a distribution block with a wiring harness, I checked the harness and the connectors.
1980 Euro 635CSI

Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests