Help Support Bigcoupe.com

1980 635CSi Euro

Document your Sixer project here.

Moderators: ron, bfons, GRNSHRK

User avatar
tschultz
Bigcoupe supporter
Posts: 2419
Joined: Wed Jul 07, 2010 10:54 pm
Location: Colorado
Contact:

Re: 1980 635CSi Euro

Post by tschultz » Wed May 15, 2019 12:39 pm

Decided on a way to share some family news:

Image

Should be a busy fall for us!

The 635 started up and ran to be able to get the photos, but sputtered close to home. I got it running again to get the photos, unfortunately after 5 restarts, it didn't want to start again. I replaced the ICU, combo relay and recently the fuel pump and tried a spare CTS. I am starting to suspect a solder joint issue inside the ECU.

May open it up in the next week to check...

User avatar
tschultz
Bigcoupe supporter
Posts: 2419
Joined: Wed Jul 07, 2010 10:54 pm
Location: Colorado
Contact:

Re: 1980 635CSi Euro

Post by tschultz » Mon Mar 16, 2020 2:31 am

So the car hasn't been cooperating and won't start for me now. I haven't had a lot of chance to continue diagnosing and I have tried the following without luck:

Spare Ecu
New Ignition control Unit
Spare distributor
spare combo relay
New ballast resistor
New rotor
replacement fuel pump
spare coolant temp sensor
replacement batter cable
new spark plugs
new coil
Proper timing with the distributor

Not sure what to try next. Maybe spark plug cables or verify what I am seeing spark...

In the mean time I wanted to make some progress and so I installed a new Raid steering wheel. 340mm like what I had, but leather, not suede. It looks great, I'm just sad I couldn't test drive it! I had the alpina horn button and installed that.

Image

Image

I haven't driven this car enough the past 3 years, especially in the last 1 calendar year!! My wife doesn't like it because it has an exhaust leak/smell that I haven't been able to eliminate (no cats? but also it gets in the cabin with windows open).

Quietlion79
Posts: 34
Joined: Sat Nov 16, 2019 10:29 pm
Location: Los Angeles

Re: 1980 635CSi Euro

Post by Quietlion79 » Thu Mar 26, 2020 2:41 pm

Hey Tom,

Hope you figure it out soon! I was hoping for some good news for you on that front, but I guess the steering wheel will have to do for now! As far as the exhaust leak goes, once it is up and running again, have the car running and cover the tailpipe(s) with a rag, that will make the leak more apparent so that you can locate it. Maybe at one of the manifolds to downpipes? Hope that helps and best of luck tracking down your no start issue.

If you want to try to locate the leak without the engine running, Chrisfix has a neat method.

https://www.youtube.com/watch?v=N-exs1iMLFU
Last edited by Quietlion79 on Thu Mar 26, 2020 3:08 pm, edited 1 time in total.
1952 Austin Sheerline Limo RHD
1963 Chrysler 300J 413 Dual Quad
1964 Jensen CV8 Mk2 383 RHD
1964 Buick Riviera (Sold)
1970 AMC Rebel Machine 390 4 speed
1981 BMW Euro 635CSI (Tom's car)
1989 Chrysler Conquest 2.6 turbo
2001 Honda Insight 5 spd Turbo

User avatar
80euro Csi
Posts: 11
Joined: Wed Jul 18, 2012 9:31 pm
Location: Vancouver, WA

Re: 1980 635CSi Euro

Post by 80euro Csi » Thu Mar 26, 2020 2:58 pm

Hey you guys, you keep copying me with your mail. I'm not offended but thought you should know my email is 80Euro Csi and not 1980 635Csi Euro.
Thanks and hope you all are well. Take care
Neal
80euro Csi

User avatar
tschultz
Bigcoupe supporter
Posts: 2419
Joined: Wed Jul 07, 2010 10:54 pm
Location: Colorado
Contact:

Re: 1980 635CSi Euro

Post by tschultz » Thu Mar 26, 2020 3:03 pm

Thanks Andy! I haven't gone in depth like this but I do wonder if some of it has to do with the lack of a cat. convertor. When I get it running again I will have to try that solution as I previosuly found a cracked exhaust manifold.

I am following along with Robert's euro E12 that seems to have similar problems:

https://www.firstfives.org/phpBB-3.2.1/ ... f=4&t=5884

Next step is when I get a chance, use a helper and check for spark and try and move backward through the system starting at the coil.

Quietlion79
Posts: 34
Joined: Sat Nov 16, 2019 10:29 pm
Location: Los Angeles

Re: 1980 635CSi Euro

Post by Quietlion79 » Thu Mar 26, 2020 3:09 pm

Wish I could help ya out. I figure I owe you one after all those calls and texts. ;)

I'll bet it is some kind of wring issue, bad connection or pinched wire....it has to be...you've covered everything else! Unless both ECU's have the same lifted solder joint problem...
1952 Austin Sheerline Limo RHD
1963 Chrysler 300J 413 Dual Quad
1964 Jensen CV8 Mk2 383 RHD
1964 Buick Riviera (Sold)
1970 AMC Rebel Machine 390 4 speed
1981 BMW Euro 635CSI (Tom's car)
1989 Chrysler Conquest 2.6 turbo
2001 Honda Insight 5 spd Turbo

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest