Help Support Bigcoupe.com

Stereo head unit interface issues :(

Post in this forum for topics relating to the interior.

Moderators: ron, bfons, GRNSHRK

Post Reply
GRNSHRK
Platinum Member
Platinum Member
Posts: 3280
Joined: Thu Apr 08, 2004 3:24 pm
Location: Gilroy (SF Bay Area) CA

Stereo head unit interface issues :(

Post by GRNSHRK » Wed Dec 15, 2021 11:45 pm

OK gents, I'm having a real bitch of a time getting my old Sony pullout stereo head unit to make a good solid connection with the mating connector ](*,)

I can get all channels to work, but it requires moving the individual connectors around, specifically one channel, as 3 out of 4 work reliably :-"

I've tried contact cleaner, springing out the contact points farther to make a better connection, even filing the contact surfaces, which probably isn't the best idea either [-X

At this point I'm open for suggestions, as this is starting to drive me crazy and I would like to wrap this project up [-o<

As usual, TIA :wink:
Attachments
Head unit interface connector.JPG
Head unit interface connector.JPG (534.54 KiB) Viewed 731 times
:mrgreen:
Bobbo
1980 633 CSi Cypress Green/Pearl Beige
2017 X5 M Sport Xdrive 35i Carbon Black/Ivory White
2005 330 Ci ZHP Cabrio Imola Red/Bone/Black
Image

User avatar
hornhospital
Platinum Member
Platinum Member
Posts: 2781
Joined: Sun Jul 11, 2010 6:46 pm
Location: Silverhill, AL
Contact:

Re: Stereo head unit interface issues :(

Post by hornhospital » Fri Dec 17, 2021 5:09 am

My suspicion is the poor contact is within the removable plate rather than the plate/head unit interface itself. Those have a certain amount of flex within the plate, and the flex is responsible for the failing/failed connections.
Ken Kanne
'84 633CSi "Sylvia"; '85 635CSi "Katja";'85 325e "Hazel Ann";'87 325is "Odette"; '93 325is "Elvira"; '95 M3 "Ashlyn"; '95 318is "Bebe"

GRNSHRK
Platinum Member
Platinum Member
Posts: 3280
Joined: Thu Apr 08, 2004 3:24 pm
Location: Gilroy (SF Bay Area) CA

Re: Stereo head unit interface issues :(

Post by GRNSHRK » Sat Dec 18, 2021 10:17 pm

Ken, are you referring to the type of head unit that had a removeable front panel :-k

This is not that type, the entire head unit slides in and out, making contact when inserted, hopefully [-o<

I'm going to work on checking the alignment, a suggestion from Craig in Paso, after discussing this issue with him earlier today :-"

Hope you're feeling better Ken, and check your email when you get a chance \:D/
:mrgreen:
Bobbo
1980 633 CSi Cypress Green/Pearl Beige
2017 X5 M Sport Xdrive 35i Carbon Black/Ivory White
2005 330 Ci ZHP Cabrio Imola Red/Bone/Black
Image

User avatar
hornhospital
Platinum Member
Platinum Member
Posts: 2781
Joined: Sun Jul 11, 2010 6:46 pm
Location: Silverhill, AL
Contact:

Re: Stereo head unit interface issues :(

Post by hornhospital » Sat Dec 18, 2021 11:38 pm

Yes, I was thinking of the removable faceplate type unit. I misunderstood.

Gradually getting better. Appetite is back! LOL!
Ken Kanne
'84 633CSi "Sylvia"; '85 635CSi "Katja";'85 325e "Hazel Ann";'87 325is "Odette"; '93 325is "Elvira"; '95 M3 "Ashlyn"; '95 318is "Bebe"

633_Dream
Posts: 16
Joined: Thu Dec 16, 2021 9:29 pm
Location: EU

Re: Stereo head unit interface issues :(

Post by 633_Dream » Tue Dec 21, 2021 6:29 pm

I would not be surprised if the connectors solder joints inside radio are cracked.

Typically the plug should be fine. There is no corrosion visible.

You might also check if any of the pins is not bent or made flat after some time of usage. It happens.

GRNSHRK
Platinum Member
Platinum Member
Posts: 3280
Joined: Thu Apr 08, 2004 3:24 pm
Location: Gilroy (SF Bay Area) CA

Re: Stereo head unit interface issues :(

Post by GRNSHRK » Wed Dec 22, 2021 11:12 pm

I've been inside the unit as well, a few times, checking things, but the leads go to connectors, no solder joints to crack :-"

I'm still thinking that the interface has issues, possibly alignment, as suggested by a fellow board member =D>

But there are 2 alignment pins so you really can't misalign it, once you slide the head unit it [-X

I was just working on it again today, to no avail ](*,)

I am really temped at this point to hard wire everything :twisted:
:mrgreen:
Bobbo
1980 633 CSi Cypress Green/Pearl Beige
2017 X5 M Sport Xdrive 35i Carbon Black/Ivory White
2005 330 Ci ZHP Cabrio Imola Red/Bone/Black
Image

Post Reply

Who is online

Users browsing this forum: No registered users and 6 guests