On board computer (blank)

Post here for mechanical and engine topics such as fuel issues, transmission problems, rough idle, exhaust, electrical issues, etc

Moderators: GRNSHRK, ron, bfons

Post Reply
blackbirdxx
Posts: 70
Joined: Wed Mar 13, 2013 1:39 pm
Location: London UK

On board computer (blank)

Post by blackbirdxx »

Hi,
Took the central console out to remove the carpet recently. Thought it a good opportunity to swap out the screen on my obc. Problem is, with the screen now replaced and connected up, the screen is completely blank. The screen lights up but nothing else.

Was hoping that someone can help me. All was working before I opened it up.
Many thanks in advance...

1986 BMW E24
blackbirdxx
Posts: 70
Joined: Wed Mar 13, 2013 1:39 pm
Location: London UK

Re: On board computer (blank)

Post by blackbirdxx »

I managed to get hold of a replacement 13 button obc out of a 1986 e28 5 series. Can anyone confirm that all 13 button obc's are interchangeable as this unit appears dead also. The only thing I did before removing the console and obc was to replace the obc computer module box under the dash as the car was not starting. The original obc was working fine then.

any ideas please
thanks in advance

bmw e24 1986
blackbirdxx
Posts: 70
Joined: Wed Mar 13, 2013 1:39 pm
Location: London UK

Re: On board computer (blank)

Post by blackbirdxx »

Something else before I forget....
I'm not sure what the white push in socket at the back of the obc is for? Original obc white socket says 6.1 Type. The recently sought obc white socket reads 6.3 Type.
plip1953
Posts: 420
Joined: Mon Aug 13, 2018 4:15 pm
Location: Leeds

Re: On board computer (blank)

Post by plip1953 »

Does the unit you're trying to install have a part number on it? If so, you could perhaps see if this matches what was already in your car (or a known working one). And then check in RealOEM. The same part number certainly appears across several models of that time.
Phil
__________________________

1988 Highline 635 CSi
blackbirdxx
Posts: 70
Joined: Wed Mar 13, 2013 1:39 pm
Location: London UK

Re: On board computer (blank)

Post by blackbirdxx »

Hi, thx for responding.
The part number for the new obc is identical to the one removed. I have swapped over the white push in module at the back to let it know what car it is.
When the obc is plugged in, all that illuminates is the screen. The rest of the unit appears dead just like the one I removed. I get the feeling that it must be a connection somewhere but not sure how I should go about checking?
plip1953
Posts: 420
Joined: Mon Aug 13, 2018 4:15 pm
Location: Leeds

Re: On board computer (blank)

Post by plip1953 »

Have you searched for other threads re OBCs? At a quick glance there seem to be quite a few that mention a main relay, but also the context mainly seems to be for cars that won't start. Whereas your car starts and runs fine, but nothing showing on the OBC display? It seems there's also an internal fuse in the OBC and I have a vague memory of there being a bulb for illumination purposes.
Phil
__________________________

1988 Highline 635 CSi
Post Reply